Initial commit
[yaffs-website] / node_modules / node-sass / src / libsass / contrib / libsass.spec
1 Name:           libsass
2 Version:        %{version}
3 Release:        1%{?dist}
4 Summary:        A C/C++ implementation of a Sass compiler
5
6 License:        MIT
7 URL:            http://libsass.org
8 Source0:        %{name}-%{version}.tar.gz
9
10 BuildRequires:  gcc-c++ >= 4.7
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14
15
16 %description
17 LibSass is a C/C++ port of the Sass engine. The point is to be simple, fast, and easy to integrate.
18
19 %package        devel
20 Summary:        Development files for %{name}
21 Requires:       %{name}%{?_isa} = %{version}-%{release}
22
23
24 %description    devel
25 The %{name}-devel package contains libraries and header files for
26 developing applications that use %{name}.
27
28
29 %prep
30 %setup -q
31 autoreconf --force --install
32
33
34 %build
35 %configure --disable-static \
36            --disable-tests \
37            --enable-shared
38
39 make %{?_smp_mflags}
40
41
42 %install
43 %make_install
44 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
45
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51
52 %files
53 %doc Readme.md LICENSE
54 %{_libdir}/*.so.*
55
56 %files devel
57 %doc
58 %{_includedir}/*
59 %{_libdir}/*.so
60 %{_libdir}/pkgconfig/*.pc
61
62
63 %changelog
64 * Tue Feb 10 2015 Gawain Lynch <gawain.lynch@gmail.com> - 3.1.0-1
65 - Initial SPEC file
66